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 This chapter explains how you can use the Virtual Phone user interface to test your telephony applications. 





   Virtual Phone Window  ^TOP^








 The Virtual Phone window, shown in Figure 4.1, displays the text equivalent of the original Telephony Manager function,
while the actual AT commands or traces are displayed in the AT Log window. 





   Figure 4.1  Virtual Phone window










 This window displays the Telephony Manager functions that are called and the results of the calls. 





   Virtual Phone Menu Items ^TOP^








 Most of Virtual Phone's functions are available through the following menu items. 



   File Menu  ^TOP^








 Select File to work with Virtual Phone configuration files (VPC files). 





   File > New Profile






 Select to open the New Profile wizard to create a new Virtual Phone configuration. 





   File > Open Phone Config
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 Select to open the Open dialog, shown in Figure 4.2, to select an existing Virtual Phone configuration file. 





   Figure 4.2  Open dialog for Virtual Phone configuration (VPC) files











   File > Save Phone Config






 Select to save the current Virtual Phone configuration file. 





   File > Save Phone Config As






 Select to open the Save VP State dialog, shown in Figure 4.3, to save the current Virtual Phone configuration file with a
filename that you specify. 





   Figure 4.3  Save VP State Dialog











   File > Exit






 Select to exit Virtual Phone. 



   Connection Menu  ^TOP^








 Select Connect to connect the Virtual Phone to the Simulator. Select Disconnect to disconnect the Virtual Phone from
the Simulator. Select Reset to clear the Activity Log without disconnecting the Virtual Phone.



   View Menu  ^TOP^








 Select View to open or arrange the secondary Virtual Phone windows. 





   View > AT Log






 Select to open the AT Log window, shown in Figure 4.4. 
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   Figure 4.4  AT Log window 









  
 -  To save the contents of the AT Log window, click the diskette icon in the toolbar. 

  
 -  To add a separator line to the window, click the line icon in the toolbar. 

  
 -  To clear the contents of the window, click the delete icon (the red X) in the toolbar. 

  
 -  To view the contents of the window in hexadecimal format, click the hex icon (the black H) in the toolbar. 







   View > Auto Arrange AT Log 






 Select to position the AT Log window below the Virtual Phone window. 





   View > Auto Arrange AT+CFG






 Select to position the AT Log window to the right of the Virtual Phone window, and the Phone Configuration dialog below
the Virtual Phone window. 





   View > Auto Arrange CFG+AT






 Select to position the AT Log window to below the Virtual Phone window, and the Phone Configuration dialog to the right
of the Virtual Phone window. 



   Tools Menu  ^TOP^








 The Tools menu, shown in Figure 4.5, provides access to several services.





   Figure 4.5  Virtual Phone Tools Menu











   Tools > Phone Configuration






 Select to open the Phone Configuration dialog to set and view the settings for basic services of Virtual Phone. See
"Phone Configuration Dialog" for more information. 
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   Tools > Services






 Select to open the Service Configuration dialog to set and view the settings for PhoneBook, SMS, and Speech services.
See "Service Configuration Dialog" for more information. 





   Tools > Send AT Commands






 Select to open a dialog, shown in Figure 4.6, where you can enter AT unsolicited results that you want to send. 





   Figure 4.6  Send AT Commands Dialog 











   Tools > Responses Preferences






 Select to define the Virtual Phone services, error numbers, and messages. See "Response Preferences Dialog" for more
information. 





   Tools > Options






 Select to define the options for Profiles, Phone use, and window settings. See "" for more information. 





   Tools > Profile Setup 






 Select to change or view current Profile settings. See "Profile Setup Dialog" for more information. 





   Virtual Phone Toolbar Items ^TOP^








 Virtual Phone provides additional functions through the toolbar shown in Figure 4.7. 





   Figure 4.7  Virtual Phone toolbar 











   AT Button 
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 Toggles the display of the AT Log window. 





   Clear Button 






 Clears the contents of the Activity Log 





   Connection Button 






 Connects or disconnects Virtual Phone. 





   Power Button 






 Turns Virtual Phone on or off, determining whether Virtual Phone can receive AT commands. 





   CFUN Button 






 Turns the phone functions on or off (equivalent to processing the AT+CFUN command). 





   Network Registration Button 






 Registers the phone to the operator selected (equivalent to processing the AT+COPS=0 command). 





   Virtual Phone Status Bar  ^TOP^








 The status bar, shown in Figure 4.8, displays information about the current configuration. 



  
 -  The communications plug-in link setting 

  
 -  The phone plug-in setting 

  
 -  The security state (such as Ready, PIN Expected, PUK Expected) 







   Figure 4.8  Virtual Phone status bar 
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   Phone Configuration Dialog  ^TOP^








 The Phone Configuration dialog provides access to the phone configuration settings. To open the Phone Configuration
dialog, select Tools > Phone Configuration. 



   Phonebook Settings ^TOP^








 Phonebook Settings, shown in Figure 4.9, displays information about the stored phone books, showing the current
phonebook and which phonebooks are activated. Note that the list of phone books depends on the settings in your
profile. 





   Figure 4.9  Phonebook Settings











   General





  
 -  Maximum Name Length

   

 Enter the maximum length of a name associated to a phone number. A maximum of 30 characters is permitted for the
name length. 

   

 See alp_tel_phb_get_phonebook in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Phonebook Service.







   Current Phone Book






 The currently selected Phone Book. 




 See alp_tel_phb_get_phonebook or alp_tel_phb_set_phonebook in the ACCESS Linux Platform SDK API
documentation under Modules>Telephony>Telephony Mgr>Phonebook Service. 





   Activated Phone Books 
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 Check to indicate that the phone book is to be created, if it does not already exist) and then subsequently updated. Each
phone book that you check is created and updated in the Phonebooks folder. If a phone book is not checked, it is not
created (or if it already exists, it is not updated).




 See alp_tel_phb_get_phonebooks in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Phonebook Service.



   SMS Settings ^TOP^








 SMS Settings, shown in Figure 4.10, displays information about the SMS features. 





   Figure 4.10  SMS Settings 










 The values entered and displayed here are stored in the SMS (Short Message Services) files, SmsStore.db and
SmsStoreSend.db.





   General setting





  
 -  Call Center

   

 Enter the phone's service center. 

   

 See alp_tel_cfg_set_sms_center or alp_tel_cfg_get_sms_center in the ACCESS Linux Platform SDK API documentation
under Modules>Telephony>Telephony Mgr>Configuration Service. 

  
 -  Max SMS Index

   

 Enter the maximum number of messages to display and store (maximum 500). 

   

 See alp_tel_sms_get_storage in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>SMS Services. 

  
 -  SMS Loopback

   

 Check this option to apply a loopback on the SMS sent by the simulator. This means that the Message Type Indicator is
changed from <Submit> to <Deliver>. This loopback provides SMS test facilities.







   MO SMS Service






 Select the SMS bearer service for Mobile Originated SMS: 
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 -  0 - GPRS

  
 -  1 - Circuit Switched

  
 -  2 - GPRS Preferred 

  
 -  3 - Circuit switch preferred






 See alp_tel_sms_set_bearer_service or alp_tel_sms_get_bearer_service in the ACCESS Linux Platform SDK API
documentation under Modules>Telephony>Telephony Mgr>SMS Services. 





   New Message indication






 Select the mode for new messages: 



  
 -  0 - Always buffer unsolicited result codes 

  
 -  1 - Discard unsolicited results when link is reserved

  
 -  2 - Buffer unsolicited results when link is reserved 







   Indication mode according to SMS type





  
 -  SMS Deliver

   

 Select the SMS Deliver setting: 

  

    
 -  0 - No indications are routed 

    
 -  1 - Memory location is routed (+CMTI)

    
 -  2 - PDU is routed (+CMT)

  

  
 -  SMS Status Report

   

 Select the SMS Status Report setting: 

  

    
 -  0 - No indications are routed 

    
 -  1 - PDU is routed (+CDS)

    
 -  2 - Memory location is routed (+CDSI)

  

  
 -  SMS Cell Broadcast
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 Select the SMS Cell Broadcast setting: 

  

    
 -  0 - No indications are routed 

    
 -  1 - Memory location is routed (+CBMI)

    
 -  2 - PDU is routed (+CBM)

  





   Data Settings  ^TOP^








 Data Settings, shown in Figure 4.11, displays information about the server, server port, communication protocol. 





   Figure 4.11  Data Settings 











   Server 






 These settings are used for data connections (GSM/GPRS). The server specified should be a valid TCP server. 



  
 -  Server

   

 Enter the name of the server. 

  
 -  Port

   

 Enter the port for the server. 

  
 -  Protocol

   

 Select the communication protocol for the server (TCP or UDP). 





   SIM Settings  ^TOP^








 SIM Settings, shown in Figure 4.12, displays SIM properties for the phone you are emulating. 





   Figure 4.12  SIM Settings 
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   International Mobile Subscriber Identity





  
 -  IMSI - International Subscriber Identity 

   

 Enter the international mobile subscriber identity number corresponding to the SIM card. 







   Voice Mail Number 





  
 -  Number 

   

 Enter the voice mail number for the SIM card. 

  
 -  Name

   

 Enter the voice mail name for the SIM card. 







    NOTE:  The Voice Mail Number settings are disabled by default. Click Enable to activate these settings.









   SIM Card





  
 -  Status 

   

 Sim Inserted: Select this setting to indicate whether the SIM card is in use for the emulation. 

   

 Provisioning: Select this setting to indicate whether the SIM card is provisioned (emulating the presence of WAP
provisioning files such as bootstrap, config1, or config2)





   GPRS Settings  ^TOP^








 GPRS Settings, shown in Figure 4.13, displays GPRS properties for the phone you are emulating. 





   Figure 4.13  GPRS Settings 











   GPRS Network registration 
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 -  State 

   

 Specify the network registration state for the Mobile Equipment (ME).

  

    
 -  0 - Not Registered, ME Not Searching. 

    
 -  1 - Registered

      

 Select this value if the highlighted network is registered to a provider (RegStat=1).

    
 -  2 - Not Registered, ME Not searching

      

 Select this value if the network is not registered (RegStat=2).

    
 -  3 - Registration Denied

      

 Select this value to simulate a denied registration (RegStat=3).

    
 -  4 - Unknown

      

 Select this value if the network is not recognized by Virtual Phone (RegStat=4).

    
 -  5 - Registered, Roaming 

      

 Select this value if the network is registered as roaming (RegStat=5). 

   

 See alp_tel_nwk_get_status in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Network Service. 

  

  
 -  Attach to GPRS Network

   

 Select to indicate whether the phone is attached to the GPRS network. 

   

 See alp_tel_nwk_get_gprs_registration in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Network Service. 







   Location 





  
 -  Cell Id 

   

 Enter the value of the current cell. This value is a two-byte cell ID in hexadecimal format. 

   

 See alp_tel_nwk_get_location in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Network Service. 

  
 -  Area Code 
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 Enter the value of the cell's area code. This value is a two-byte location area code in hexadecimal format. 

   

 See alp_tel_nwk_get_location in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Network Service. 







   Network Registration Notification 





  
 -  Mode 

   

 Set the network registration notification state.

  

    
 -  0 - None

      

 Select this value to disable the network registration unsolicited results code.

    
 -  1 - Network Reg.

      

 Select this value to enable the network registration unsolicited results code.

    
 -  2 - Network Reg. & Location Info

      

 Select this value to enable the network registration and location information unsolicited results code.

  

  
 -  Send Notif

   

 Click to send a network registration notification. Note that if you modify the Cell ID or Area Code information, you should
click Apply before clicking Send Notif. 







   GPRS Event Reporting 






 Use the following options to enable or disable the sending of unsolicited result codes (+CGEV) to the terminal when
certain events occur in the Packet Domain MT or the network



  
 -  Mode

   

 Select the buffering mode for event reporting. 

  

    
 -  0 - Buffered: Select this value to buffer unsolicited result codes. No codes are forwarded to the terminal.

    
 -  1 - Discard when On Line: Select this value to discard unsolicited result codes in on-line data mode.

    
 -  2 - Buffer when On Line: Select this value to buffer unsolicited result codes in on-line data mode.
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 -  Bfr

   

 Select the buffer behavior.

  

    
 -  0 - Clear: Select this value to clear the buffer when <mode> 1 or 2 is entered

    
 -  1 - Flush: Select this value to flush the buffer to the terminal when <mode> 1 or 2 is entered

  





   GPRS PDP Management ^TOP^








 The Phone Configuration dialog provides one settings page for overall settings, and an additional page for each APN
specified. 





   Figure 4.14  PDP Management 











   PDP Context Management 






 The table lists the APN definitions for this Virtual Phone session. The PDP parameters available depend on the selected
PDP type. 





   Actions 





  
 -  Activate: Click to activate the selected PDP context.

  
 -  Deactivate: Click to deactivate the selected PDP context.

  
 -  Add: Click to add a new PDP context.

  
 -  Remove: Click to remove the selected PDP context.

   

 See alp_tel_ps_get_pdp_activation in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Packet Switch Service. 







   Unsolicited Result Codes 





  
 -  Reject 

   

 Click to send an unsolicited result code indicating that a network request for PDP context activation was automatically
rejected.
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 -  ME Deact

   

 Click to send an unsolicited result code indicating that the mobile termination has forced a context deactivation.

  
 -  ME Detach 

   

 Click to send an unsolicited result code indicating that the mobile termination has forced a PS detach. This implies that
all active contexts have been deactivated.

  
 -  NW React 

   

 Click to send an unsolicited result code indicating that the network has requested a context reactivation.

  
 -  NW Deact 

   

 Click to send an unsolicited result code indicating that the network has forced a context deactivation.

  
 -  NW Detach

   

 Click to send an unsolicited result code indicating that the network has forced a PS detach. This implies that all active
contexts have been deactivated.







   Class 





  
 -  Selection

   

 Choose the class which indicates the mode of operation

  
 -  NW Class 

   

 Click to send an unsolicited result code indicating that the network has forced a change of the mobile termination (id
VirtualPhone) class. 

  
 -  ME Class 

   

 Click to send an unsolicited result code indicating that the mobile termination (id VirtualPhone) has forced a change of its
class.

  
 -  Flush Result 

   

 Click to display the result in the AT Log.







   Figure 4.15  MyAPN 










 Each APN defined has a page for defining packet data protocol parameters. 
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   Packet Data Protocol Parameters





  
 -  Context Identifier: This parameter identifies the defined PDP context.

  
 -  Type: Select the type of packet data protocol.

  
 -  APN: Enter the Access Point Name (used to select the GGSN or the external packet data network).

  
 -  Address: Enter the address applicable to the PDP.







   Type Parameters





  
 -  PD1, PD2,PD3

   

 String parameters with meanings that are specific to the OSPIH PDP type.







   Compression





  
 -  Header 

   

 Check to set the PDP header compression ON.

  
 -  Data 

   

 Check to set the PDP data compression ON.

   

 See alp_tel_ps_set_context and alp_tel_ps_get_context in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Packet Switch Service. 







   Required Quality 






 Use these options to specify a Quality of Service Profile:



  
 -  Precedence: Select the value for the precedence class.

  
 -  Delay: Select the value for the delay class.

  
 -  Reliability: Select the value for the reliability class.

  
 -  Peak: Select the value for the peak throughput class.

  
 -  Mean: Select the value for the mean throughput class.
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 See alp_tel_ps_get_qos_requested in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Packet Switch Service. 







   Minimum Quality






 Use these options to specify a minimum acceptable QoS profile:



  
 -  Precedence: Select the value for the precedence class.

  
 -  Delay: Select the value for the delay class.

  
 -  Reliability: Select the value for the reliability class.

  
 -  Peak: Select the value for the peak throughput class.

  
 -  Mean: Select the value for the mean throughput class.

   

 See alp_tel_ps_get_qos_minimum in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Packet Switch Service.





   Speech Settings ^TOP^








 Speech Settings, shown in Figure 4.16, displays properties for speech calls. 





   Figure 4.16  Speech Settings 











   Connected Line ID present





  
 -  TA 

   

 Check to show the result code presentation status in the Terminal Adapter (TA) phone book. 

  
 -  Nwk 

   

 Check to show the subscriber connected line identification presentation service status in the network phone book. 







   Calling Line ID Present





  
 -  TA 
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 Check to show the result code presentation status in the Terminal Adapter (TA) phone book. 

  
 -  Nwk 

   

 Check to show the subscriber connected line identification presentation service status in the network phone book.







   Calling Line ID Restriction 





  
 -  Subscription 

   

 Set according to the subscription of the calling line identification restriction service. 

  
 -  On Network 

   

 Set to the subscriber calling line identification restriction service status in the network. 







   Supplementary Service Notifications





  
 -  +CSSI 

   

 Select to indicate whether +CSSI notifications are supported. 

  
 -  +CSSU 

   

 Select to indicate whether +CSSU notifications are supported. 





   Speech Forwarding  ^TOP^








 Speech Forwarding, shown in Figure 4.17, displays information about call forwarding settings. 





   Figure 4.17  Speech Forwarding 











   Call Forwarding 





  
 -  Reason 

   

 Select the reason for call forwarding: 
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 -  Unconditional

      

 Select this option to always forward. 

    
 -  Busy

      

 Select this option to forward when the line is busy. 

    
 -  No Reply

      

 Select this option to forward when there is no reply. 

    
 -  Not Reachable

      

 Select this option to forward when the line is not reachable. 

  

  
 -  Class 

   

 Select the call type that you want forwarded: 

  

    
 -  Voice

      

 Select this option to forward incoming voice calls. 

    
 -  Data

      

 Select this option to forward incoming data calls.

    
 -  Fax

      

 Select this option to forward incoming fax calls. 

    
 -  Sms

      

 Select this option to forward incoming SMS messages. 

    
 -  Data Circuit Sync

      

 Select this option to forward incoming synchronous data service calls. 

    
 -  Data Circuit Async

      

 Select this option to forward incoming asynchronous data service calls.

    
 -  Dedicated Packet Access

      

 Select this option to forward incoming dedicated packet access service calls. 

    
 -  Dedicated PAD Access
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 Select this option to forward incoming dedicated PAD access service calls. 

  

  
 -  Status: Active

   

 Check to indicate that call forwarding is active. 

  
 -  Number

   

 Enter the phone number of the forwarding address. 

  
 -  SubAddr

   

 Enter the call forwarding subaddress. 

  
 -  Time

   

 Enter the time in seconds to wait before call is forwarded. Note that this setting applies only when Call forwarding by
class is set to No Reply. 







   Advice of Charge






 The Advice of Charge settings, shown in Figure 4.18, enables you to set the values for notifications of phone charges.
See "Speech - Advice Of Charge" for information on using this feature.





   Figure 4.18  Speech Advice of Charge













  
 -  CCCM notification enabled

   

 Check to enable unsolicited CCCM notifications, which are sent when the current call meter value changes.

  
 -  CCWV Notification enabled

   

 Check to enable CCWV notification, which is fired shortly before the ACM maximum value is reached.

  
 -  ACM Max

   

 Specify a maximum value for the Accumulated Call Meter (ACM).

  
 -  PPU

   

 Specify the price per unit.
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 -  Currency Code

   

 Specify the type of currency, such as EUR for euros, DOL for dollars, and so forth. This is for identification purposes, so
you can use any currency value you choose.





   Configuration Settings ^TOP^








 The Configuration Settings, shown in Figure 4.19, provides access to basic Virtual Phone configuration parameters. 





   Figure 4.19  Configuration Settings 











   Phone Settings 






 Enter the information for the phone you want to emulate. 



  
 -  Brand

   

 Enter any name (limited to 30 alphanumeric characters). 

   

 Use the function alp_mbl_context_gsm_get_manufacturer to access this information. See the ACCESS Linux Platform
SDK API documentation under Modules>Telephony
>Mobile Services>GSM Mobile Context. 

  
 -  Model

   

 Enter any model number (limited to 30 alphanumeric characters). 

   

 Use the function alp_mbl_context_gsm_get_model to access this information. See the ACCESS Linux Platform SDK API
documentation under Modules>Telephony
>Mobile Services>GSM Mobile Context. 

  
 -  Revision

   

 Enter the revision number (limited to 30 alphanumeric characters). 

   

 Use the function alp_mbl_context_gsm_get_revision to access this information. See the ACCESS Linux Platform SDK
API documentation under Modules>Telephony
>Mobile Services>GSM Mobile Context. 

  
 -  Number

   

 Enter the Phone Number (limited to 30 alphanumeric characters) of the "virtual" mobile phone. 
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 Use the function alp_mbl_context_get_own_number to access this information. See the ACCESS Linux Platform SDK
API documentation under Modules>Telephony
>Mobile Services>GSM Mobile Context. 

   

 The Phone number can also be set or retrieved through the functions alp_tel_cfg_set_phone_number or
alp_tel_cfg_get_phone_number. See the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Configuration Service.. 

  
 -  Serial Number

   

 Enter the serial number of the phone you are emulating. 

   

 Use the function alp_mbl_context_gsm_get_mobile_id to access this information. See the ACCESS Linux Platform SDK
API documentation under Modules>Telephony
>Mobile Services>GSM Mobile Context. 

  
 -  The information (Brand, Model, Revision, Serial Number) can also be retrieved through the function
alp_tel_inf_get_identification. See the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Information Service. 







   Network Settings





  
 -  Emc Number

   

 Enter the emergency call number. 





   Configuration Facilities ^TOP^








 Configuration Facilities, shown in Figure 4.20, displays information about the current emulation session. 





   Figure 4.20  Configuration Facilities 











   Facilities 





  
 -  Select the facility from the list:

  

    
 -  AI-Bar All Incoming Calls

    
 -  AO-Bar All Outgoing calls

    
 -  FD-SIM fixed dialing memory feature

    
 -  IR-Bar incoming calls when roaming outside the home country
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 -  OI-Bar Outgoing International calls

    
 -  OX-Bar Outgoing international calls eXcept to home country

    
 -  PF-Lock phone to the first inserted SIM card

    
 -  PN-Network Personalization 

    
 -  PS-Lock phone to SIM card

    
 -  PU-Network Subset Personalization

    
 -  

    
 -  SC-SIM asks for password in ME power-up

  

  
 -  Mode 

   

 Select Lock to indicate that the facility lock is active or select Unlock to indicated that it is not active.

  
 -  Passwd

   

 Enter the facility lock password.

  
 -  Class 

   

 Select the class of information. Call barring facilities are based on GSM supplementary services (refer GSM 02.88 [6]).
The interaction of these with other commands is based on other GSM supplementary services as described in the GSM
standard. See the selection descriptions in the "Call Forwarding" section.





   Network Settings  ^TOP^








 Network Settings, shown in Figure 4.21, displays properties that simulate network-oriented services, including
authorized networks, forbidden networks, current network, signal strength, and search mode.





   Figure 4.21  Network Settings 










 Set the parameters for the network you are emulating.





   Signal Strength 






 Set the signal level you want to test. 



  
 -  Entry field 
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 Enter a numeric value between 0 and 31, with 0 being no signal and 31 being the maximum signal strength. 

   

 See alp_tel_nwk_get_signal_level See the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Network Service. 

  
 -  Not detectable

   

 If checked, Virtual Phone will issue a 99 for Signal Strength. As specified in the GSM Technical Specification. 







   Search Mode 






 Select how you want Virtual Phone to select a network.



  
 -  Manual 

   

 Select this value if you want Virtual Phone to manually select a network

  
 -  Auto

   

 Select this value if you want Virtual Phone to automatically select a network. 

   

 See alp_tel_nwk_set_registration_mode and alp_tel_nwk_get_registration_mode in the ACCESS Linux Platform SDK
API documentation under Modules>Telephony>Telephony Mgr>Network Service. 







   Network name presentation 






 Select how you want the network name presented:



  
 -  0-Long Name

  
 -  1-Short Name

  
 -  2-Numeric Name





   Network Notifications ^TOP^








 Network Notifications, shown in Figure 4.22, displays information about the network location and registration
notifications. 





   Figure 4.22  Network Notifications 
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   Location






 Set the location information for the current cell and its area code. 



  
 -  Cell Id 

   

 Enter the value of the current Cell. This value is a two-byte cell ID in hexadecimal format. 

   

 See alp_tel_nwk_get_location in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Network Servicek. 

  
 -  Area Code

   

 Enter the value of the Cell's area code. This value is a two-byte location area code in hexadecimal format. 

   

 See alp_tel_nwk_get_location in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Network Service. 







   Network Registration Notification State 






 Set the network registration notification state. 



  
 -  0 - None

   

 Select this value to disable the network registration unsolicited results code. 

  
 -  1 - Network Reg.

   

 Select this value to enable the network registration unsolicited results code. 

  
 -  2 - Network Reg. & Location Info 

   

 Select this value to enable the network registration and location information unsolicited results code. 

  
 -  Send Notif button 

   

 Click to send a network registration notification. Note that if you modify the Cell ID or Area Code information, you should
click Apply before clicking Send Notif. 





   Network Networks  ^TOP^
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 Network Networks, shown in Figure 4.23, displays information about the networks used for this Virtual Phone session. 





   Figure 4.23  Network Networks 











   Networks 






 Specify the networks for your phone. 



  
 -  Current List

   

 Select a list of network from either the Available Networks list or the Preferred Networks list. Select Modify List to display
the Network List Management dialog. 

   

 A network is defined by its SimId, Id, Short Name and Name. 






 



  

    
 -  SimId 

      

 The order number of the operator in the SIM available/preferred operator list. 

    
 -  Id

      

 This is a hexadecimal value five digits long. The first three digits represent the country code; the next two digits
represent the network name. The normal numeric format is the GSM Location Area Identification number, which consists
of a three-digit (BCD) country code plus a two-digit (BCD) network code. 

    
 -  Short Name 

      

 An abbreviation of the Name with a maximum 8 alphanumeric characters. 

    
 -  Name 

      

 The normal maximum value for name is 16 alphanumeric characters. Some operators restrict this value to 6 or 8
characters, while some networks allow more than 16 characters for the long name. 

   

 See alp_tel_nwk_get_operators and alp_tel_nwk_get_preferred_operators in the ACCESS Linux Platform SDK API
documentation under Modules>Telephony>Telephony Mgr>Network Service.
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 -  State

   

 Select the state of the network that is selected in the table. There are four options: 

  

    
 -  Unknown 

      

 Select this value if the network unknown (Stat=0). 

    
 -  Available

      

 Select this value if the selected network is available (Stat=1).

    
 -  Current

      

 Select this value if the highlighted network is currently selected (Stat=2). 

    
 -  Forbidden

      

 Select this value if the network is unavailable for security reasons (Stat=3). 

   

 See alp_tel_nwk_set_operator in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Network Service. 

  

  
 -  ME Reg State

   

 Select the ME (Mobile Equipment, that is the GSM phone) network registration status.

  

    
 -  1 - Registered 

      

 Select this value if the highlighted network is registered to a provider (RegStat=1).

    
 -  2 - Not Registered, ME Not searching 

      

 Select this value if the network is not registered (RegStat=2).

    
 -  3 - Registration Denied 

      

 Select this value if the network is secured and registration is rejected (RegStat=3). 

    
 -  4 - Unknown 

      

 Select this value if the network is not recognized by Virtual Phone (RegStat=4).

    
 -  5 - Registered, Roaming 

      

 Select this value if the network is registered as roaming (RegStat=5).

   

 See alp_tel_nwk_get_status in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Network Service.
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   Power Settings ^TOP^








 Use Power Settings to enter the power information for the phone you are emulating. 





   Figure 4.24  Power Settings 











   Power management 





  
 -  Phone Functionality Value 

   

 Enter a number indicating the phone functionality status as defined in ETSI standard (see AT+CFUN command). 

   

 See alp_tel_pow_get_phone_functionality and alp_tel_pow_set_phone_functionality in the ACCESS Linux Platform SDK
API documentation under Modules>Telephony>Telephony Mgr>Power Service. 

  
 -  Battery state 

   

 Enter the battery conditions you are testing. 

  

    
 -  Powered 

      

 Select to indicate that the battery is present and that the Battery Level setting should be taken into consideration. 

    
 -  Not Powered

      

 Select to indicate that the battery is present but its power level is zero. 

    
 -  No Battery

      

 Select to indicate that no battery is present. 

    
 -  Battery Fault 

      

 Select to simulate a battery fault condition. 

   

 See alp_tel_pow_get_battery_connection_status in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Power Service. 

  

  
 -  Battery level
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 Select the battery range from 0% (for no power) to 100% (for full power). 

   

 See alp_tel_pow_get_battery_charge_level in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Power Service. 





   Security Codes  ^TOP^








 Security Codes, shown in Figure 4.25, displays information about security settings used for this emulation session. 





   Figure 4.25  Security Codes 










 You can change the values of these codes in this dialog. 

   

 You can change the PIN1 and PIN2 codes by using the function alp_tel_sty_change_facility_password. See the
ACCESS Linux Platform SDK API documentation under Modules>Telephony>Telephony Mgr>Security Service. 





   PIN 1





  
 -  Value 

   

 Enter the primary Personal Identification Number (PIN), between 4-digits and 8-digits long. 

  
 -  Num tries

   

 Enter the number of times that a user can attempt to enter the PIN 1 value. 







   PIN 2





  
 -  Value 

   

 Enter the secondary Personal Identification Number between, 4-digits and 8-digits long. 

  
 -  Num tries

   

 Enter the number of times that a user can attempt to enter the PIN 2 value. 







   PUK 1
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 -  Value 

   

 Enter the primary Personal Universal Key (PUK). This value is a mandatory 8-digits long. 

  
 -  Num tries 

   

 Enter the number of times that a user can attempt to enter the PUK 1 value. 







   PUK 2





  
 -  Value 

   

 Enter the secondary Personal Universal Key (PUK). This value is a mandatory 8-digits long. 

  
 -  Num tries 

   

 Enter the number of times that a user can attempt to enter the PUK 2 value. 






 The relevant values in this dialog are checked against the value set in the function alp_tel_sty_enter_authentication. See
the ACCESS Linux Platform SDK API documentation under Modules>Telephony>Telephony Mgr>Security Service. 





   Reset State






 Click to reset the security values to the default state. 



   Security Status ^TOP^








 Use Security Status to set the security for this Virtual Phone session. 





   Figure 4.26  Security Status 











   Actual Security Status 






 Enter the security state of the phone. 
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 See alp_tel_sty_get_authentication_status in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Security Service. 



  
 -  Ready

   

 Select this value if Virtual Phone is ready to receive AT commands. State=0. 

   

 In this state, Virtual Phone answers "Ready" to any +CPIN? command, and does not apply PIN Security before
answering other AT commands. 

  
 -  PIN1 expected 

   

 Select this value to indicate that Virtual Phone should expect a primary Personal Identification Number (PIN). State=1. 

  
 -  PUK1 expected 

   

 Select this value to indicate that Virtual Phone should expect the primary Personal Universal Key (PUK). State=3. 

  
 -  Phone to SIM expected

   

 Select this value to indicate that Virtual Phone should expect the Phone to Subscriber Identification Module (SIM) code.
State=5. 

  
 -  Phone to First SIM expected

   

 Select this value to indicate that Virtual Phone should expect the Phone to First SIM Key (PH-FSIM PIN).

  
 -  PIN2 expected 

   

 Select this value to indicate that Virtual Phone should expect a secondary Personal Identification Number (PIN).
State=2. 

  
 -  PUK2 expected 

   

 Select this value to indicate that Virtual Phone should expect the secondary Personal Universal Key (PUK). State=4. 

  
 -  SIM Wrong

   

 Select this value to simulate a deactivated SIM card, such as a SIM card with the PUK code blocked







   Lock SIM Card 






 Check to activate PIN1 security. 





   Service Configuration Dialog  ^TOP^
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 To open the Service Configuration dialog, select Tools > Services. The Service Configuration dialog displays settings for
PhoneBook, SMS, SIM, and Speech. 



   PhoneBook  ^TOP^








 The PhoneBook page, shown in Figure 4.27, displays information about each of the active phonebooks. 





   Figure 4.27  PhoneBook 










 See alp_tel_phb_get_phonebooks in the ACCESS Linux Platform SDK API documentation under
Modules>Telephony>Telephony Mgr>Phonebook Service.



  
 -  Write Protected 

   

 Check to indicate that the phone book is write protected. 

  
 -  Total Entries 

   

 Enter the maximum number of entries allowed in the phone book.

  
 -  Total Used

   

 The value in this field indicates the number of entries present in the selected phonebook.

  
 -  Add button 

   

 To manually add an entry in the phone book, click Add. This generates an index entry for the item, and you can click on
the fields in the table to add data. 

  
 -  Remove button 

   

 To remove an entry, select the entry and click Remove. 

  
 -  Remove All button 

   

 To remove all entries in the phone book, click Remove All. 

  
 -  Populate button 

   

 To add random data to the phone book, click Populate. 





   SMS PDU Viewer  ^TOP^
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 Use PDU Viewer, shown in Figure 4.28, to create a new SMS delivery message, which is an SMS message received by
Virtual Phone from the GSM network. The message is stored in the first available location in the SmsStore.db file. 





   Figure 4.28  PDU Viewer 











   PDU Viewer 





  
 -  PDU 

   

 Enter the PDU (Protocol Data Unit) for this message. 







   Action 





  
 -  Direction 

   

 Select whether this is an incoming message or an outgoing message. 

  

    
 -  Incoming SMS (SC to MS) - Select if this is an incoming message. 

    
 -  Outgoing SMS (MS to SC) - Select if this is an outgoing message. 

  

  
 -  Decode 

   

 Click to decode this message. 





   SMS PDU Manager  ^TOP^








 Use the PDU Manager page to set options for the SMS Center. 





   Figure 4.29  PDU Manager











   SMS Center 





  
 -  Configured in MS 
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 Check to indicate that the SMS Center is configured in the MS (Mobile Station). 

  
 -  Address

   

 Enter the address of the SMS Center. This option is available when the SMS Center is configured in MS checkbox is not
selected. 

  
 -  TON 

   

 Select the "Type of Numbering (TON)" phone number format: 

  

    
 -  Unknown - Address octet 129 ISDN

    
 -  International - Address octet 145 ISDN

    
 -  National - Address octet 161 ISDN 

  

  
 -  Message Parameters 

   

 Enter the other message data in the scrollable table. 

  
 -  Create PDU button

   

 Click to create a PDU. 

  
 -  Reset

   

 Click to reset the data to the default data. 

  
 -  Receive PDU button 

   

 Click to receive a PDU. 






 With the default Virtual Phone configuration, you can create a standard SMS message by clicking Receive PDU. Virtual
Phone creates a Class 1 SMS text message with the text Hello world! 




 To create a multiple-part SMS message, simply add enough characters to the message. 



   SMS Storage  ^TOP^








 The SMS Storage page shows the content of the memory area that is used for SMS reading, writing, deleting, sending,
or receiving. 





   Figure 4.30  SMS Storage 
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   Messages 





  
 -  Id

   

 The identification number of the message. 

  
 -  Type

   

 The message type. 

  
 -  Multi Part

   

 Indicates whether the SMS is composed of several parts. For a single-part message, the field says None. For a multiple-
part message, the field contains a relative number indicating the part displayed, such as 1/3 for the first part of a three-
part message. 

  
 -  Status

   

 Indicates the status of the message: received unread, received read, stored unsent, or stored sent. 

  
 -  Message Text

   

 Content of the SMS message. 

  
 -  Refresh button

   

 Click to refresh the messages table. 

  
 -  Delete button

   

 Click to delete a selected message. To select a message, either use Ctrl+A or else Ctrl-click the message. 





   SMS Log  ^TOP^








 The SMS Log page keeps a record of SMS messages you have sent. 





   Figure 4.31  SMS Log











   Messages 





  
 -  Id 
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 The identification number of the message.

  
 -  Multi Part

   

 The SMS is composed of several parts. 

  
 -  Status 

   

 Indicates the status of the message: should always be set to stored sent. 

  
 -  Report Status

   

 The SMS contains a status report request. 

  
 -  Message Text

   

 Content of the SMS message. 

  
 -  Refresh List button

   

 Click to refresh the messages table. 

  
 -  Send Report button

   

 Click to send an SMS status report for the selected SMS message (if applicable). 

  
 -  Delete button

   

 Click to delete a selected message. To select a message, either use Ctrl+A or else Ctrl-click the message. 





   Speech - New Call ^TOP^








 Use the New Call page to create a new call.





   Figure 4.32  New Call 











   New Incoming Call





  
 -  Name 

   

 Enter the name for the incoming call. 

  
 -  Number 
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 Enter the phone number for the incoming call. 

  
 -  Forwarded 

   

 Check if you want this call treated as a forwarded incoming call. 

  
 -  Start 

   

 Click to make the call you have created.





   Speech - Manage Calls ^TOP^








 The Manage Calls page allows you to change the state of calls that you have placed or received





   Figure 4.33  Speech - Manage Calls











   Speech - Advice Of Charge ^TOP^








 The Advice of Charge page allows you to send a notification that includes the current call meter value of the call. The
values used for the notification are set in Phone Configuration dialog. See the "Advice of Charge" for more information.




 





  
 -  Set AoC interval (in s)

   

 Sets the timer that will increment the current call meter value by the specified number of seconds. Press Start to start the
timer. Once the timer has started, the button text changes to Stop, and you can press the button to stop the timer.

  
 -  +CCCM notification

   

 Press Start to start the timer to send the notification every 10 seconds. After you press Start, the button text changes to
Stop, and you must press the button to stop the notification.

  
 -  +CCWV notification

   

 Press Send to send the notification that simulates that a "maximum value" has been reached.







   Response Preferences Dialog ^TOP^
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 To open the Response Preferences dialog, select Tools > Response Preferences. Use this screen to select an error
which will systematically be returned by a service. 





   Figure 4.34  Response Preferences Dialog














 For more details regarding the AT command set, see the 3GPP TS 27007 specification: "AT command set for User
equipment"




 The following list associates a Virtual Phone service to a Telephony Manager function as supported by a standard GSM
phone driver.



 Table 4.1  Virtual Phone Services and Telephony Manager FunctionsÂ 





  

     Services

    

     Associated Functions

    

  

  

     Accept Call

    

     alp_tel_spc_accept_call 

    

  

  

     Add Entry

    

     alp_tel_phb_add_entry 

    

  

  

     Auto Operator Select

    

     alp_tel_nwk_set_registration_mode

    

  

  

     Call Number

    

     alp_tel_spc_initiate_call

    

  

  

     Change Authentication Code

    

     alp_tel_sty_change_facility_password 
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     Close Line and Reject Call

    

     alp_tel_spc_release_call 

    

  

  

     Delete Entry

    

     alp_tel_phb_delete_entry 

    

  

  

     Delete Message

    

     alp_tel_sms_delete_message 

    

  

  

     Enter Authentication Code

    

     alp_tel_sty_enter_authentication 

    

  

  

     Get Authentication State

    

     alp_tel_sty_get_authentication_status 

    

  

  

     Get available Storage

    

     alp_tel_sms_get_storages

    

  

  

     Get Available Phone Books

    

     alp_tel_phb_get_phonebooks 

    

  

  

     Get Battery State

    

     alp_tel_pow_get_battery_connection_status

    

  

  

     Get Brand Number

    

     alp_tel_inf_get_identification

    

  

  

     Get Call State

    

     alp_tel_spc_get_call 

    

  

  

     Get Entries

    

     alp_tel_phb_get_entries 
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     Get Location

    

     alp_tel_nwk_get_location 

    

  

  

     Get Model Number

    

     alp_tel_inf_get_identification

    

  

  

     Get Mute status

    

     alp_tel_snd_get_mute_status 

    

  

  

     Get Networks

    

     alp_tel_nwk_get_operators

    

  

  

     Get Network status

    

     alp_tel_nwk_get_status 

    

  

  

     Get Phone Number

    

     alp_tel_cfg_get_phone_number

    

  

  

     Get Revision

    

     alp_tel_inf_get_identification

    

  

  

     Get Selected Phone Book

    

     alp_tel_phb_get_phonebook 

    

  

  

     Get Selected Network

    

     alp_tel_nwk_get_operator 

    

  

  

     Get Selected Storage

    

     alp_tel_sms_get_storage 

    

  

  

     Get Signal Level

    

     alp_tel_nwk_get_signal_level
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     Get Sms Center

    

     alp_tel_cfg_get_sms_center

    

  

  

     Hold Line

    

     alp_tel_spc_hold_active_calls

    

  

  

     Mute

    

     alp_tel_snd_set_mute_status 

    

  

  

     Operator Select

    

     alp_tel_nwk_set_operator

    

  

  

     Read Message

    

     alp_tel_sms_read_message 

    

  

  

     Read Messages

    

     alp_tel_sms_read_messages 

    

  

  

     Select Phone Book

    

     alp_tel_phb_set_phonebook 

    

  

  

     Select SMS Storage

    

     alp_tel_sms_set_storage 

    

  

  

     Send DTMF tones

    

     alp_tel_spc_play_tone

    

  

  

     Send Short Message

    

     alp_tel_sms_send_message 

    

  

  

     Set Phone Number
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     alp_tel_cfg_set_phone_number

    

  

  

     Set Sms Center

    

     alp_tel_cfg_set_sms_center

    

  













   Response Configuration





  
 -  According to Phone's State

   

 Select this option to return a value according to the current state of Virtual Phone.

  
 -  Reply with Error

   

 Use this option to return the selected error message.







   Options Dialog ^TOP^







 Table 4.2  GSM General ErrorsÂ 





  

     GSM Error Number

    

     Error

    

     Telephony Constant

    

  

  

     0

    

     Phone failure

    

     ALP_STATUS_TEL_COMMAND_FAILED

    

  

  

     1

    

     No connection to phone

    

     ALP_STATUS_TEL_PHONE_COMM

    

  

  

     2
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     Phone-adapter link reserved

    

     ALP_STATUS_TEL_PHONE_COMM

    

  

  

     3

    

     Operation not allowed

    

     ALP_STATUS_TEL_OPERATION_NOT_ALLOWED

    

  

  

     4

    

     Operation not supported

    

     ALP_STATUS_TEL_FEATURE_NOT_SUPPORTED

    

  

  

     5

    

     PH-SIM PIN required

    

     ALP_STATUS_TEL_PHONE_TO_SIMPIN_REQUIRED

    

  

  

     10

    

     SIM not inserted

    

     ALP_STATUS_TEL_NO_SIM_INSERTED

    

  

  

     11

    

     SIM PIN required

    

     ALP_STATUS_TEL_SIMPIN_REQUIRED

    

  

  

     12

    

     SIM PUK required

    

     ALP_STATUS_TEL_SIMPUK_REQUIRED

    

  

  

     13

    

     SIM failure

    

     ALP_STATUS_TEL_SIM_FAILURE

    

  

  

     14

    

     SIM busy
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     ALP_STATUS_TEL_SIM_BUSY

    

  

  

     15

    

     SIM wrong

    

     ALP_STATUS_TEL_SIM_WRONG

    

  

  

     16

    

     Incorrect password

    

     ALP_STATUS_TEL_PASSWORD

    

  

  

     17

    

     SIM PIN2 required

    

     ALP_STATUS_TEL_SIMPIN2_REQUIRED

    

  

  

     18

    

     SIM PUK2 required

    

     ALP_STATUS_TEL_SIMPUK2_REQUIRED

    

  

  

     20

    

     Memory full

    

     ALP_STATUS_TEL_PHONE_MEM_ALLOCATION

    

  

  

     21

    

     Invalid index

    

     ALP_STATUS_TEL_INVALID_INDEX

    

  

  

     22

    

     Not found

    

     ALP_STATUS_TEL_ENTRY_NOT_FOUND

    

  

  

     23

    

     Memory failure
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     ALP_STATUS_TEL_PHONE_MEM_FAILURE

    

  

  

     24

    

     Text string too long

    

     ALP_STATUS_TEL_INVALID_STRING

    

  

  

     25

    

     Invalid characters in text string

    

     ALP_STATUS_TEL_INVALID_STRING

    

  

  

     26

    

     Dial string too long

    

     ALP_STATUS_TEL_INVALID_DIAL

    

  

  

     27

    

     Invalid characters in dial string

    

     ALP_STATUS_TEL_INVALID_DIAL

    

  

  

     30

    

     No network service

    

     ALP_STATUS_TEL_NO_NETWORK

    

  

  

     31

    

     Network time-out

    

     ALP_STATUS_TEL_NETWORK_TIMEOUT

    

  

  

     32

    

     Network not allowed -emergency calls only

    

     ALP_STATUS_TEL_NETWORK_NOT_ALLOWED

    

  

  

     40

    

     Network personalization PIN required

    

     ALP_STATUS_TEL_NETWORK_PIN_REQUIRED
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     41

    

     Network personalization PUK required

    

     ALP_STATUS_TEL_NETWORK_PUK_REQUIRED

    

  

  

     42

    

     Network subset personalization PIN required

    

     ALP_STATUS_TEL_NETWORK_SUBSET_PIN_REQUIRED

    

  

  

     43

    

     Network subset personalization PUK required

    

     ALP_STATUS_TEL_NETWORK_SUBSET_PUK_REQUIRED

    

  

  

     44

    

     Service provider personalization PIN required

    

     ALP_STATUS_TEL_PROVIDER_PIN_REQUIRED

    

  

  

     45

    

     Service provider personalization PUK required

    

     ALP_STATUS_TEL_PROVIDER_PUK_REQUIRED

    

  

  

     46

    

     Corporate personalization PIN required

    

     ALP_STATUS_TEL_CORPORATE_PIN_REQUIRED

    

  

  

     47

    

     Corporate personalization PUK required

    

     ALP_STATUS_TEL_CORPORATE_PUK_REQUIRED

    

  

  

     100

    

     Unknown

    

     ALP_STATUS_TEL_UNKNOWN

    


ACCESS Developer Network

http://www.accessdevnet.com Powered by Joomla! Generated: 9 September, 2010, 04:35



  

  

     

    

     Error 

    

     The command is not supported. 

    

  

  

     

    

     No response

    

     The phone received no response; equivalent to a ALP_STATUS_TEL_TIMEOUT

    

  







 Table 4.3  





  

     GPRS related Error Number

    

     Error

    

     Telephony Constant

    

  

  

     103

    

     Illegal MS

    

     ALP_STATUS_TEL_PS_ILLEGAL_MS

    

  

  

     106

    

     Illegal ME

    

     ALP_STATUS_TEL_PS_ILLEGAL_ME

    

  

  

     107

    

     GPRS services not allowed

    

     ALP_STATUS_TEL_PS_SERVICES_NOT_ALLOWED

    

  

  

     111

    

     PLMN not allowed

    

     ALP_STATUS_TEL_PS_PLMN_NOT_ALLOWED

    

  

  

     112
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     Location area not allowed

    

     ALP_STATUS_TEL_LOCATION_AREA_NOT_ALLOWED

    

  

  

     113

    

     Roaming not allowed in this location area

    

     ALP_STATUS_TEL_ROAMING_NOT_ALLOWED

    

  

  

     148

    

     GPRS unspecified error

    

     ALP_STATUS_TEL_PS_UNSPECIFIED_ERROR

    

  












 




 Use the Options dialog to set general options for Virtual Phone. To open the Options dialog, select Tools > Options. 



   Profiles Options  ^TOP^








 Use the Profiles page to set options for when you start and exit Virtual Phone. 





   Figure 4.35  Options - Profiles 











   Phone Options  ^TOP^








 Use the Phone page to set options for general phone simulation. 





   Figure 4.36  Options - Phone 









   Dialog Options  ^TOP^


ACCESS Developer Network

http://www.accessdevnet.com Powered by Joomla! Generated: 9 September, 2010, 04:35










 Use the Dialog page to set options for how Virtual Phone windows are handled at start-up. 





   Figure 4.37  Options - Dialog 











   Profile Setup Dialog ^TOP^








 The Profile Setup allows you to change the settings that get written to the Virtual Phone configuration file (VPC) when
you run the New Profile wizard (described in "Creating a Virtual Phone Profile"). To open the Profile Setup dialog, select
Tools > Profile Setup. 





   Figure 4.38  Profile Setup Dialog
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